频道栏目
首页 > 资讯 > 网络协议 > 正文

BGP基本配置

11-07-18        来源:[db:作者]  
收藏   我要投稿

 

 

 

R1
Current configuration : 1299 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
 
 
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback3
 no ip address
!
interface Serial0/0
 ip address 192.168.1.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 192.168.3.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 0
!
router bgp 200
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 3.3.3.3 remote-as 200
 neighbor 3.3.3.3 update-source Loopback1
 neighbor 3.3.3.3 next-hop-self
 neighbor 192.168.1.2 remote-as 100
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
End
 
 
 
 
 
R2:
Building configuration...
 
Current configuration : 1081 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
!
interface Loopback2
 ip address 2.2.2.2 255.255.255.0
!
interface Serial0/0
 ip address 192.168.1.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 192.168.2.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 100
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 network 2.2.2.0 mask 255.255.255.0
 neighbor 192.168.1.1 remote-as 200
 neighbor 192.168.2.2 remote-as 200
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
 
 
 
 
 
 
R3:
r3#show running-config
Building configuration...
 
Current configuration : 1384 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
!
interface Loopback3
 ip address 3.3.3.3 255.255.255.0
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 ip address 192.168.3.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 192.168.4.1 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 3.3.3.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 0
 network 192.168.4.0 0.0.0.255 area 0
!
router bgp 200
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 network 3.3.3.0 mask 255.255.255.0
 neighbor 1.1.1.1 remote-as 200
 neighbor 1.1.1.1 update-source Loopback3
 neighbor 4.4.4.4 remote-as 200
 neighbor 4.4.4.4 update-source Loopback3
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
End
 
 
 
 
R4:
r4#show running-config
Building configuration...
 
Current configuration : 1340 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
!
interface Loopback4
 ip address 4.4.4.4 255.255.255.0
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 ip address 192.168.2.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 192.168.4.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.0 0.0.0.255 area 0
 network 192.168.4.0 0.0.0.255 area 0
!
router bgp 200
 no synchronization
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 network 4.4.4.0 mask 255.255.255.0
 neighbor 3.3.3.3 remote-as 200
 neighbor 3.3.3.3 update-source Loopback4
 neighbor 3.3.3.3 next-hop-self
 neighbor 192.168.2.1 remote-as 100
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
本文出自 “IT梦-齐-分享” 博客
相关TAG标签
上一篇:路由器上做Easy VPN
下一篇:GRE VPN配置实例
相关文章
图文推荐

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站