频道栏目
首页 > 程序开发 > 移动开发 > Android > 正文
android 4.0 中出错 java.lang.UnsupportedOperationException
2013-07-04 10:24:51           
收藏   我要投稿

在android4.0中  画图的时候使用:
canvas.clipPath(path, Region.Op.XOR); 报错

 


java.lang.UnsupportedOperationException

 

 

 


出现原因是4.0硬件加速出的问题,我们在配置文件里面加上


 android:hardwareAccelerated="false"(sdk3.0以上,才能用)

在相应的activity里面加或者
application里面

 

 

 


<application

        android:hardwareAccelerated="false"

        android:name="com.hck.book.ui.MyApplication"

        android:icon="@drawable/icon2"

        android:label="@string/app_name"

         >

 

 

 

 


如果用的sdk是3.0以下的,配置问价里面用 android:hardwareAccelerated="false",它会直接提示你错误的。

这个时候,打开配置文件,把

 

 

 

android:targetSdkVersion="17" />

改成android:targetSdkVersion="10" />

 


10或者以下,不小于你配置的最小sdk版本,就ok了

 

点击复制链接 与好友分享!回本站首页
相关TAG标签 android 中出错
上一篇:android下获取无线wif信号、ssid、MAC等操作类
下一篇:基于Andoird 4.2.2的Account Manager源代码分析学习:AccountManager的简要工作流程
相关文章
图文推荐
点击排行

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站