频道栏目
首页 > 程序开发 > 移动开发 > Android > 正文
Android studio中添加RecyclerView报错
2018-05-07 11:31:53      个评论    来源:weixin_42149882的博客  
收藏   我要投稿

Android studio中添加RecyclerView报错。

今天学习过程中用到了RecyclerView ,但是在导入依赖包的时候出现了问题,在网上求助,效果不佳,后来在看后台errors的时候才发现是版本不同导致的问题,我花了五颗糖的时间解决,希望有同样问题的朋友能花一颗糖的时间就解决掉右键project,点击open module settings,app中选择dependencies,有个加号点击,添加libraries,选择recyclerview,一定要注意版本,点击ok后,找到build gradle下的dependences添加

compile'com.android.support:recyclerview-v7:版本号'注意,版本号一定要和运行版本一致如果不知道版本号在dependence中其他行的版本号照搬就行例如:我先看到下面这行。

implementation 'com.android.support:appcompat-v7:26.1.0',那么我的版本就是26.1.0,将RecyclerView的版本改为26.1.0,之后重新运行一下就可以使用了。

点击复制链接 与好友分享!回本站首页
上一篇:Android高性能编码 - 移动端安全规范
下一篇:Android高性能编码Top10 移动端安全问题总结
相关文章
图文推荐

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站