频道栏目
首页 > 网络 > 交换机 > 正文

华为交换机RRPP配置实验

2013-02-27 13:21:46      个评论    来源:myworldkwd 的BLOG  
收藏   我要投稿

在工作中遇到了H3C和HW的RRPP配置,以下就以华为模拟器再作一次实验。大家共同来论讨论遇到的问题。
【理论基础】
  www.2cto.com  
RRPP具体的理论见配置手册

下面只点几个容易出错的地方
1、作为RRPP环的接口要关闭STP

2、两个重要的命令:
control-vlan vlan-id命令,创建控制VLAN。
由参数vlan-id指定的控制VLAN和由vlan-id+1指定的子控制VLAN必须都是未被创建,并且未被port trunk、mapping、stacking等方式使用过的VLAN。
每个RRPP域配有两个控制VLAN,分别为主控制VLAN和子控制VLAN。配置时只需要指定主控制VLAN,而把比主控制VLAN ID值大1的VLAN作为子控制VLAN。
控制VLAN创建后不能直接修改,可以通过先删除域,然后再重新配置的方式修改,也可以通过undo control-vlan命令将控制VLAN删除后重新配置的方式修改。子控制VLAN在删除域时会被连带删除。
  www.2cto.com  
protected-vlan reference-instance { { instance-id1 [ to instance-id2 ] } &<1-10> | all },配置RRPP域的保护VLAN列表。
RRPP端口允许通过的VLAN都应该配置为保护VLAN,包括数据VLAN和控制VLAN。
 说明:
配置RRPP保护VLAN列表需要注意以下事项:
在配置RRPP环之前必须配置保护VLAN。
在配置RRPP环之前可以删除、修改已经配置的保护VLAN。在配置环之后不允许更改保护VLAN。
在同一物理拓扑中,本域的控制VLAN不能做为其他域的保护VLAN。
控制VLAN必须在保护VLAN范围内,否则不允许配置环。
控制VLAN在创建环前允许加入别的实例,在创建环后不允许更改,除非删除域。
实例和VLAN映射关系发生变化时,RRPP域的保护VLAN随之变化。
RRPP端口允许通过的所有VLAN都应该被RRPP域保护。
3、RRPP在端口下不用允许控制vlan 通过。

4、rrpp在STP域中要把控制vlan加入域中。

【实验软件和拓扑】

ENSP 1.0 模拟器,赞,这个模拟器确实不错!以前没有怎么接触,用起来挺顺手,与真实环境差不多。

交换机选择S5700


 相连接的接口如下,LSW0-G0/0/1-----------G0/0/1-LSW1-G0/0/2------------G0/0/1--LSW2-G0/0/2-----------G0/0/2-LSW1

LSW0作为主结点,0/0/2作为主端口,0/0/1作为副端口,配置完成后0/0/1在逻辑上是被阻断的。

LSW1 和LSW2 作为传输结点,传输结点的端口主副无关紧要,但是在实际项目中建议有规律地配置。

配置脚本如下:
  www.2cto.com  

<SW0>dis cu
#
sysname SW0
#
vlan batch 20 to 21
#
rrpp enable
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
stp region-configuration
 instance 1 vlan 20 to 21 100 to 300
 active region-configuration
#
rrpp domain 1
 control-vlan 20
 protected-vlan reference-instance 1
 ring 1 node-mode master primary-port GigabitEthernet0/0/2 secondary-port GigabitEthernet0/0/1 level 0
 ring 1 enable
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 20 to 21 100 to 300
 stp disable
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 20 to 21 100 to 300
 stp disable
#

[SW1]dis cu
#
sysname SW1
#
vlan batch 20 to 21
#
rrpp enable
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
stp region-configuration
 instance 1 vlan 20 to 21 100 to 300
 active region-configuration
#
rrpp domain 1
 control-vlan 20
 protected-vlan reference-instance 1
 ring 1 node-mode transit primary-port GigabitEthernet0/0/1 secondary-port GigabitEthernet0/0/2 level 0
 ring 1 enable
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 20 to 21 100 to 300
 stp disable
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 20 to 21 100 to 300
 stp disable
#

<SW2>dis cu
#
sysname SW2
#
vlan batch 20 to 21
#
rrpp enable
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
stp region-configuration
 instance 1 vlan 20 to 21 100 to 300
 active region-configuration
#
rrpp domain 1
 control-vlan 20
 protected-vlan reference-instance 1
 ring 1 node-mode transit primary-port GigabitEthernet0/0/1 secondary-port GigabitEthernet0/0/2 level 0
 ring 1 enable
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 20 to 21 100 to 300
 stp disable
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 20 to 21 100 to 300
 stp disable
#

<SW0>dis rrpp brief
Abbreviations for Switch Node Mode :
M - Master , T - Transit , E - Edge , A - Assistant-Edge

RRPP Protocol Status: Enable
RRPP Working Mode: HW
RRPP Linkup Delay Timer: 0 sec (0 sec default)
Number of RRPP Domains: 1

Domain Index   : 1
Control VLAN   : major 20  sub 21
Protected VLAN : Reference Instance 1
Hello Timer  : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)

 Ring  Ring   Node  Primary/Common   Secondary/Edge   Is
 ID  Level  Mode  Port   Port   Enabled
 ----------------------------------------------------------------------------
 1   0  M   GigabitEthernet0/0/2   GigabitEthernet0/0/1   Yes

<SW0>dis rrpp verbose domain 1
Domain Index   : 1
Control VLAN   : major 20  sub 21
Protected VLAN : Reference Instance 1
Hello Timer  : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)

RRPP Ring  : 1
Ring Level   : 0
Node Mode  : Master
Ring State   : Complete
Is Enabled   : Enable   Is Active: Yes
Primary port   : GigabitEthernet0/0/2   Port status: UP   
Secondary port : GigabitEthernet0/0/1   Port status: BLOCKED  逻辑上是阻断地,实验完成。

  www.2cto.com  

相关TAG标签 华为 交换机
上一篇:Cisco交换机VLAN接口IP地址配置
下一篇:四种常见厂商交换机SNMP配置实例
相关文章
图文推荐
热门新闻

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站