频道栏目
首页 > 网络 > 其他 > 正文

【华为】MUX VLAN配置详解

2015-10-22 16:48:39            作者:0sunjie0
收藏   我要投稿
MUX VLAN应用场景

 

    在企业网中实现客户与客户之间不可互相访问,客户与员工之间不可互相访问,员工与员工之间可以互相访问,员工与客户都可以访问服务器。

    MUX VLAN是一种二层流量隔离机制

 

MUX VLAN 分为

 

Principal VLAN (主VLAN)和 Subordinate VLAN(从VLAN),从VLAN分为Group VLAN(互通从VLAN) 和 Separate VLAN(隔离型从VLAN)

 

通信权限

 

一丶主VLAN端口可以和所有VLAN通信

二丶互通型从VLAN可以和自己vlan间成员通信和主vlan通信

三、隔离型从VLAN只能和主VLAN通信,自己VLAN的成员也不可通信

 

配置注意事项

    

    所有主机必须在同一子网

    端口必须为access模式加入vlan

    配置MUX VLAN不能用于VLANIF接口、VLAN Mapping、VLAN Stacking、Super-VLAN、Sub-VLAN的配置

 

实验拓扑

实验需求

    C2和C3模拟企业内员工,C4和C5模拟客户。要求员工之间可以互相访问并且员工可以访问服务器,客户只能访问服务器不能与其他任何人通信。

 

配置步骤

 

IP规划

 

服务器:192.168.1.10/24

C2    :192.168.1.20/24

C3    :192.168.1.30/24

C4    :192.168.1.40/24

C5    :192.168.1.50/24

 

SW1配置

 

system-view

[sw1]vlan batch 10 20 30                             //创建VLAN 10 20 30

[sw1]vlan 10                                         //进入VLAN 管理视图

[sw1-vlan10]mux-vlan                                //配置VLAN10为Principal VLAN

[sw1-vlan10]subordinate group 20                    //配置VLAN20为互通型从VLAN

[sw1-vlan10]subordinate separate 30                 //配置VLAN30为隔离型从VLAN

[sw1-vlan10]quit 

[sw1]interface g0/0/1

[sw1-GigabitEthernet0/0/1]port link-type access        //配置接口模式为access

[sw1-GigabitEthernet0/0/1]port default vlan 10        //将接口加入VLAN10

[sw1-GigabitEthernet0/0/1]port mux-vlan enable         //开启接口的mux-vlan功能

[sw1-GigabitEthernet0/0/1]interface g0/0/2

[sw1-GigabitEthernet0/0/2]port link-type access

[sw1-GigabitEthernet0/0/2]port default vlan 20

[sw1-GigabitEthernet0/0/2]port mux-vlan enable 

[sw1-GigabitEthernet0/0/2]int g0/0/3

[sw1-GigabitEthernet0/0/3]port link-type access

[sw1-GigabitEthernet0/0/3]port default vlan 20

[sw1-GigabitEthernet0/0/3]port mux-vlan enable 

[sw1-GigabitEthernet0/0/3]int g0/0/4

[sw1-GigabitEthernet0/0/4]port link-type access 

[sw1-GigabitEthernet0/0/4]port default vlan 30

[sw1-GigabitEthernet0/0/4]port mux-vlan enable 

[sw1-GigabitEthernet0/0/4]int g0/0/5

[sw1-GigabitEthernet0/0/5]port link-type access

[sw1-GigabitEthernet0/0/5]port default vlan 30

[sw1-GigabitEthernet0/0/5]port mux-vlan enable 

 

使用display mux-vlan 查看mux-vlan的信息

[sw1]display mux-vlan 

Principal Subordinate Type         Interface  

-----------------------------------------------------------------------------

10        -           principal    GigabitEthernet0/0/1

10        30          separate     GigabitEthernet0/0/4 GigabitEthernet0/0/5

10        20          group        GigabitEthernet0/0/2 GigabitEthernet0/0/3

-----------------------------------------------------------------------------

 

实验测试

C2(员工) ping C3(员工)

C2(员工) ping 服务器

C2(员工) ping C5(客户)

C4(客户)ping C5(客户)

C4 ping 服务器

相关TAG标签 华为
上一篇:DNS Mapping
下一篇:Cisco useful feature and commands
相关文章
图文推荐
文章
推荐
热门新闻

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站