频道栏目
首页 > 网络 > 其他 > 正文

虚拟局域网VLAN的配置和以太网通道

2017-08-02 14:38:46         来源:杨书凡 的BLOG   
收藏   我要投稿

VLAN (Vlan Local Area Network,虚拟局域网)技术,可以从逻辑上将一个大的网络划分为若干小的虚拟局域网。VLAN技术不仅能够控制广播,还可以增强网络的安全性。

VLAN的优势

给局域网的设计增加了灵活性,使管理员在划分工作组时,不再受限于用户所在的物理位置。具有灵活性和可扩展性等特点,还有以下好处

(1)控制广播:每个VLAN都是一个独立的广播域,减少了广播对网络资源的占用,提高了网络传输效率,一个VLAN产生广播风暴不会影响其他VLAN

(2)增强网络安全性:不同VLAN的端口之间不能直接访问,因此可限制个别主机访问服务器等资源,提高了网络的安全性

(3)简化网络管理:可以在不改变网络物理连接的情况下,任意将工作站在工作组或子网之间移动,减轻了网络管理和维护工作的负担,降低了网络维护的费用

VLAN的种类

静态VLAN:基于端口的VLAN,是目前常见的VLAN实现方式。

动态VLAN:基于MAC地址的动态VLAN,在45系列以上的交换机上可以实现这种方式。

VLAN的基本配置

1.创建VLAN

(1)VLAN数据库配置方式:

例如:创建ID为10、名称为cwb 的VLAN

Switch# vlan database

Swich(vlan)# vlan 10 name cwb

(2)全局配置模式:

例如:创建ID为20、名称为jsb 的VLAN

Switch(config)#vlan 20

Switch(config-vlan)#name jsb

2.将交换机的端口加入到相应的VLAN中

例如:将端口0-5分配到VLAN 20

Switch(config)#int range f0/0 -5

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 20

trunk的作用:就有是为了实现不同交换机上的相同VLAN之间的通信

接入链路(access):通常属于一个VLAN,客户机与交换机之间的链路就是接入链路

中继链路(trunk):可以承载多个VLAN,交换机与交换机之间的链路为中继链路实现承载多条vlan

实验案例:配置Trunk,实现相同VLAN的跨交换机通信

\

pc0和pc5属于vlan2它们之间可以相互通信,不同vlan之间pc0和pc4之间无法通信。

步骤:

(1)首先配置交换机1划分3个vlan分别为vlan2,vlan3,vlan4

\

(2)将交换机的端口对应到相应的vlan中

\

将其他端口对应到相应的vlan中即可

(3)将交换机与交换机之间的端口模式定义为trunk模式

Switch(config)# int f0/4

Switch(config-if)# switchport mode trunk

(4)在另个交换机上相同的配置配置方法

配置中继接口的封装类型

(1)ISL思科私有的标记方式

Switch(config-if)#switchport trunk encapsulation isl

(2)802.1q 国际标准,可实现不同设备之间的标记方法

Switch(config-if)#switchport trunk encapsulation doltlq

(3)自动协商模式,与临接口协商成为ISL和802.1q封装方式

Switch(config-if)#switchport trunk encapsulation negotiate

指定 NATIVE VLAN:

主要用于交换机之间存在傻瓜交换机(傻瓜交换机无法标记,无法划分vlan)

Switch(config-if)#switchport trunk native vlan vlan-id

如果不需要trunk传送某个vlan的数据,可以从trunk中删除这个vlan命令如下:

Switch(config-if)#switchport trunk allowed vlan remove vlan-id

在trunk上添加某个vlan:

Switch(config-if)#switchport trunk allowed vlan add vlan-id

验证接口模式:

Switch#show interface interface-id switchport

EthernetChanel(以太网通道)

通过捆绑多条以太链路来进行提高带宽,并运行一种机制将多条物理链路捆绑成一条逻辑链路。

以太网通道遵循以下规则:

(1)参与捆绑的端口必须属于同一vlan

(2)链路两端的端口必须一致,如交换机某端口为中继模式那么相邻交换机的那个端口也必须为中继模式

(3)所有参与捆绑的端口物理参数必须相同,应该有相同的速率和全/半双工模式

案例:配置以太网通道

\

在交换机SW1的配置如下:

Switch(config)# int range f0/1 -2

Switch(config-if-range)# channel-group 1 mode on

在交换机SW2上做同样的配置

上一篇:交换机链路聚合技术之负载均衡算法原理
下一篇:交换机的工作原理
相关文章
图文推荐
文章
推荐
热门新闻

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站