频道栏目
首页 > 网络 > 其他 > 正文

在三层交换机上实现DHCP中继实验二-老赵网络-51CTO博客

2019-04-10 14:40:05           
收藏   我要投稿

在三层交换机上实现DHCP中继实验二

要求:三层交换机连接两个部门设计部和市场部,分别处于vlan10和vlan20中,vlan10的网关地址为192.168.10.1/24,vlan20的网关地址为192.168.20.1/24,在三层交换机上做DHCP服务器的代理功能,在路由器上配置DHCP服务为两个部门提供IP地址、网关、DNS服务器等网络参数。

Switch>en
Switch#conf t
Switch(config)#vlan 10 创建vlan
Switch(config-vlan)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface f0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10 把接口划入到vlan 10
Switch(config-if)#interface f0/1
Switch(config-if)#switchport access vlan 20 把接口划入到vlan 20
Switch(config-if)#exit
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.10.1 255.255.255.0 配置vlan 10 虚接口
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#ip add 192.168.20.1 255.255.255.0 配置vlan 20 虚接口
Switch(config-if)#exit
Switch(config)#interface f0/3
Switch(config-if)#no switchport 关闭二层接口(否则地址配置不上去)
Switch(config-if)#ip add 192.168.100.1 255.255.255.0 配置三层交换机的接口地址
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.100.2 做一条到外网的默认路由
Switch(config)#interface vlan 10
Switch(config-if)#ip helper-address 192.168.100.2 在虚接口下做中继代理指向DHCP服务器
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#ip helper-address 192.168.100.2 在虚接口下做中继代理指向DHCP服务器
Switch(config-if)#


Router>
Router>en
Router#conf t

Router(config)#in
Router(config)#interface f0/0
Router(config-if)#ip add 192.168.100.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 192.168.10.0 255.255.255.0 192.168.100.1
做两条路由指向两个部门
Router(config)#ip route 192.168.20.0 255.255.255.0 192.168.100.1
Router(config)#service dhcp
Router(config)#ip dhcp pool vlan10 创建vlan10DHCP地址池
Router(dhcp-config)#network 192.168.10.0 255.255.255.0
配置可分配的地址段
Router(dhcp-config)#default-router 192.168.10.1 设置分配的网关地址
Router(dhcp-config)#dns-server 8.8.8.8 设置DNS服务器地址
Router(dhcp-config)#exit
Router(config)#ip dhcp pool vlan20
Router(dhcp-config)#network 192.168.20.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.20.1
Router(dhcp-config)#dns-server 222.222.222.222
Router(dhcp-config)#exit

检验设计部和市场部的PC能否自动获取到地址,如果可以证明实验成功。

好知识,才能预见未来

赞赏

0人进行了赞赏支持

相关TAG标签
上一篇:DCHP基本配置及中继实验一-老赵网络-51CTO博客
下一篇:DHCP服务器和DHCP中继的配置-lonely 清风-51CTO博客
相关文章
图文推荐
文章
推荐
热门新闻

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站