频道栏目
首页 > 系统 > Linux > 正文

SUSE 10.2 Linux下配置Eclipse开发环境

2010-06-10 13:52:32      个评论      
收藏   我要投稿
 

要运行Eclipse,必须要有Java运行环境的支持。安装完SUSE 10.2后,系统会带有Java的GNU编译器GCJ(这是我个人安装选项)。

可以测试下:

hitisp:/opt # java -version

java version "1.4.2"

gij (GNU libgcj) version 4.1.2 20061115 (prerelease) (SUSE Linux)

Copyright (C) 2006 Free Software Foundation, Inc.

This is free software; see the source for copying conditions. There is NO

warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

一般,都是使用Sun的Java编译器JDK,可以从java.sun.com下载“jdk-1_5_0_14-linux-i586.bin”,将其移到/opt目录下,为了使其可执行,使用如下命令:

hitisp:/opt # chmod +x jdk-1_5_0_14-linux-i586.bin

然后就可以直接运行:

hitisp:/opt # ./jdk-1_5_0_14-linux-i586.bin

这时如果执行"java -version"还是显示如上的“1.4.2”,这是因为我还没配置环境,可以修改个人用户主目录下的.bashrc文件:

set JAVA_HOME=/opt/jdk1.5.0_14

set PATH=$JAVA_HOME/bin:$PATH

set CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar

export JAVA_HOME

export PATH

export CLASSPATH

与Windows不同的是,Linux变量之间分隔符用“:”而不是“;”。

我们可以测试一下,重新登陆后:

hitisp:/ # java -version

java version "1.5.0_14"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_14-b03)

Java HotSpot(TM) Client VM (build 1.5.0_14-b03, mixed mode)

从www.eclipse.org下载“eclipse-SDK-3.2.2-linux-gtk.gz”,我安装SUSE时使用的是GNOME,所以使用GTK版本。当然,KDE的也可以使用GTK版本。

把eclipse解压缩到/opt目录下,就可以像Windows下那样使用了。

注:/opt目录只是我选择的目录,读者可以使用任一自己喜欢的目录。

相关TAG标签 环境
上一篇:2013年将有两成中高阶手机使用Linux系统
下一篇:关于Linux操作系统根文件系统的启动分析
相关文章
图文推荐

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站