频道栏目
首页 > 网络 > 交换机 > 正文

交换机vlan+vrrp+stp

2017-07-15 15:58:48      个评论    来源:fxl风 的BLOG   
收藏   我要投稿

拓扑图:

\

配置代码:

sw1------------

sys

vlan 10

vlan 20

quit

 

int e0/0/1

port link-type access

port default vlan 10

int e0/0/2

port link-type access

port default vlan 20

int e0/0/3

port link-type trunk

port trunk allow-pass vlan all

int e0/0/4

port link-type trunk

port trunk allow-pass vlan all

quit

 

(每个交换机都配)

stp region-configuration

region-name fxl

revision-level 1

instance 1 vlan 10

instance 2 vlan 20

active region-configuration

quit

 

sw2--------------

sys

vlan 10

vlan 20

quit

 

int e0/0/1

port link-type access

port default vlan 10

int e0/0/2

port link-type access

port default vlan 20

int e0/0/3

port link-type trunk

port trunk allow-pass vlan all

int e0/0/4

port link-type trunk

port trunk allow-pass vlan all

quit

 

stp region-configuration

region-name fxl

revision-level 1

instance 1 vlan 10

instance 2 vlan 20

active region-configuration

quit

 

sw3--------------

sys

vlan 10

vlan 20

quit

 

(g0/0/3和g0/0/4端口聚合)

interface eth-trunk 1

quit

interface g0/0/3

eth-trunk 1

quit

interface g0/0/4

eth-trunk 1

quit

interface eth-trunk 1

port link-type trunk

port trunk allow-pass vlan all

quit

 

int g0/0/1

port link-type trunk

port trunk allow-pass vlan all

int g0/0/2

port link-type trunk

port trunk allow-pass vlan all

quit

 

stp region-configuration

region-name fxl

revision-level 1

instance 1 vlan 10

instance 2 vlan 20

active region-configuration

quit

stp instance 1 priority 4096(配置stp使sw3成为vlan10的根)

 

 

(配置g0/0/5ip)

vlan 100

int vlanif 100

ip add 10.0.0.1 24

int g0/0/5

port link-type access

port default vlan 100

quit

 

(配置vrrp 使sw4down掉时数据可从sw3通过)

int vlanif 10(与sw4中的vlan10对比)

ip add 192.168.10.252 24

vrrp vrid 1 virtual-ip 192.168.10.254(sw3和sw4都配这虚拟ip)

vrrp vrid 1 priority 200(数据从优先级大的通过)

vrrp vrid 1 track interface g0/0/5 reduced 150

(配置端口追踪,当g0/0/5down掉时将vrid 优先级减150)

quit

 

int vlanif 20(与sw4中的vlan20对比)

ip add 192.168.20.252 24

vrrp vrid 2 virtual-ip 192.168.20.254

vrrp vrid 2 priority 150

quit

 

rip

version 2

network 192.168.10.0

network 192.168.20.0

network 10.0.0.0

quit

 

sw4--------------

sys

vlan 10

vlan 20

quit

 

(g0/0/3和g0/0/4端口聚合)

interface eth-trunk 1

quit

interface g0/0/3

eth-trunk 1

quit

interface g0/0/4

eth-trunk 1

quit

interface eth-trunk 1

port link-type trunk

port trunk allow-pass vlan all

quit

 

int g0/0/1

port link-type trunk

port trunk allow-pass vlan all

int g0/0/2

port link-type trunk

port trunk allow-pass vlan all

quit

 

(配置stp使sw4成为vlan20的根)

stp region-configuration

region-name fxl

revision-level 1

instance 1 vlan 10

instance 2 vlan 20

active region-configuration

quit

stp instance 2 priority 4096

 

 

(配置g0/0/5ip)

vlan 200

int vlanif 200

ip add 20.0.0.1 24

int g0/0/5

port link-type access

port default vlan 200

quit

 

int vlanif 10

ip add 192.168.10.253 24

vrrp vrid 1 virtual-ip 192.168.10.254

vrrp vrid 1 priority 150

quit

 

(配置vrrp 使sw4down掉时数据可从sw3通过)

int vlanif 20

ip add 192.168.20.253 24

vrrp vrid 2 virtual-ip 192.168.20.254

vrrp vrid 2 priority 200

vrrp vrid 2 track interface g0/0/5 reduced 150

quit

 

rip

version 2

network 192.168.10.0

network 192.168.20.0

network 20.0.0.0

quit

 

 

R1---------

sys

int g0/0/0

ip add 10.0.0.2 24

int g0/0/1

ip add 20.0.0.2 24

int g0/0/2

ip add 30.0.0.254 24

quit

 

rip

version 2

network 10.0.0.0

network 20.0.0.0

network 30.0.0.0

quit

上一篇:交换机stp配置
下一篇:Cisco PT模拟实验之交换机的基本配置与管理
相关文章
图文推荐

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训

版权所有: 红黑联盟--致力于做实用的IT技术学习网站