频道栏目
首页 > 网络 > 路由器 > 正文

通过固定IP或拨号上网配置cisco路由

2017-11-07 10:02:13      个评论    来源:wang6501081 的BLOG   
收藏   我要投稿

首先介绍固定IP上网配置:

现有客户需要使用思科的2811路由器上网,用户为10M光纤,申请了16个固定IP,

IP为58.240.160.2-58.240.160.14, 默认网关是58.240.160.1。内网IP段192.168.1.0,

客户要实现192.168.1.10-192.168.1.20之间的IP可以上网,其余的不可以。

路由器e1/0接口为WAN外网接口,e1/1为LAN内网接口

拓扑图如下:

6a4ce3d785eb80b17ae9cfb41210e3b9.jpg

Cisco2811#configure terminal

Cisco2811(config)#interface ethernet 1/0 进入ethernet 1/0接口(该端口直接连接Internet)

Cisco2811(config-if)#ip address 58.240.160.2 255.255.255.240 设置端口IP

//这里可以使用58.240.160.2-14地址中的任意一个,这里就用2

Cisco2811(config-if)#ip nat outside 设置该端口为nat地址映射的外部接口

Cisco2811(config-if)#full-duplex 设置端口双工模式为全双工

Cisco2811(config-if)#no shutdown 启用端口

Cisco2811(config-if)#interface ethernet 1/1 进入ethernet 1/1接口(该端口为内部网络)

Cisco2811(config-if)#ip address 192.168.1.1 255.255.255.0设置端口IP

Cisco2811(config-if)#ip nat inside 设置该端口为nat地址映射的内部接口

Cisco2811(config-if)#full-duplex 设置端口双工模式为全双工

Cisco2811(config-if)#no shutdown 启用端口

Cisco2811(config-if)#exit

//下面设置放行的IP地址可以访问外网列表

Cisco2811(config)#no access-list 1 先取消出厂状态下的访问控制列表1

Cisco2811(config)#access-list 1 permit host 192.168.1.10 单独允许一台主机访问

Cisco2811(config)#access-list 1 permit host 192.168.1.11

Cisco2811(config)#access-list 1 permit host 192.168.1.12

Cisco2811(config)#access-list 1 permit host 192.168.1.13

Cisco2811(config)#access-list 1 permit host 192.168.1.14

Cisco2811(config)#access-list 1 permit host 192.168.1.15

Cisco2811(config)#access-list 1 permit host 192.168.1.16

Cisco2811(config)#access-list 1 permit host 192.168.1.17

Cisco2811(config)#access-list 1 permit host 192.168.1.18

Cisco2811(config)#access-list 1 permit host 192.168.1.18

Cisco2811(config)#access-list 1 permit host 192.168.1.19

Cisco2811(config)#access-list 1 permit host 192.168.1.20

//如果需要允许一个网段访问命令为:access-list 1 permit 192.168.1.0 0.0.0.255

允许192.168.1.0/24的网段访问

Cisco2811(config)#ip nat pool intoout 58.240.160.2 58.240.160.14 netmask 255.255.255.240

//定义从ISP供应商哪里申请到的公网IP地址,这里定义了一个nat地址池,名称为“natout”,在这个地址池里所定义的IP地址(58.240.160.2到58.240.160.14)将被内网的用户任意选择可用的外网IP上网。如果ISP服务商只给了一个IP地址(如58.240.160.2),那这里可以写成“ip nat pool natout 58.240.160.2 58.240.160.2 netmask 255.255.255.240”

Cisco2811(config)#ip nat inside source list 1 pool intoout overload

//将访问控制列表1与地址池‘intoout’进行对应式绑定。意思是说所有的“192.168.1.10-192.168.20”内的主机在上网时,它的内网地址都将被转换为“58.240.160.2-58.240.160.14”中

的任意一个外网地址。后面的“overload”则表示如果有多于地址池中定义的地址数量(比如原来有10个用户上网,他们各自用的外网地址是58.240.160.2、58.240.160.3、58.240.160.4、58.240.160.5、58.240.160.6、58.240.160.7、58.240.160.8、58.240.160.9、58.240.160.10、58.240.160.11)。如果现在突然有30多个用户上网了,这是就会按照上面的命令执行一个任务,那就是让多个内网用户使用同一个外网地址,如果说如果有很多用户需要上外网就必须加上overload命令,否则将导致只能同时允许公网IP地址数的用户上网。

Cisco2811(config)#ip route 0.0.0.0 0.0.0.0 58.240.160.1

//设置默认网关,即外网IP地址的网关地址为下一跳地址。这样配置后就可以上网了,但是客户端必须设置固定IP,配置DNS,如果不配置,因为没有开启DHCP服务,所以必须设置固定IP。

下面开启DHCP,则需要这样配置:

Cisco2811(config)#ip dhcp pool DHCP-test 定义一个DHCP地址池名称

Cisco2811(dhcp-config)#network 192.168.1.0 定义DHCP地址池的网络地址范围

Cisco2811(dhcp-config)#default-router 192.168.1.1 设定默认路由(即网关)

Cisco2811(dhcp-config)#dns-server 221.6.4.66 设定DNS地址(此处为移动的DNS地址)

Cisco2811(dhcp-config)#ip dhcp excluded-address 192.168.1.1 DHCP动态地址池中需要除去网关的地址,否则网关地址也会被动态分配,从而造成冲突了。

*  如果没有ip的限制,就是单纯的整个子网都可以上网,删除那个access-list 1 permit host 192.168.1.10 至access-list 1 permit host 192.168.1.20

增加 access-list 1 permit 192.168.1.0 0.0.0.255就可以了。

PPPOE拨号上网配置:

对以设置PPPOE上网,以太网接口LAN的配置不变,需要更改外网口WAN的配置和访问控制列表,

增加VPDN的配置。假设用户名是admin,密码 123456,配置过程如下:

此案例为XX电信adsl PPPoE接入,需要使用一个普通adsl modem和一台cisco 2600路由器(双以太口),IOS 12.2(15)T,能够实现局域网共享上网。

此案例配置共分7步:

第一步:配置vpdn

vpdn enable (启用路由器的虚拟专用拨号网络——vpnd)

vpdn-group office (建立一个vpdn组,名称为office)

request-dialin (初始化一个vpnd tunnel,建立一个请求拨入的vpdn子组,)

protocol pppoe (vpdn子组使用pppoe建立会话隧道)

第二步: 配置路由器连接adsl modem的接口(即连接ISP供应商设备的端口)

interface Ethernet1/0 (外网接口)

no ip address

pppoe enable 允许以太接口运行pppoe

pppoe-client dial-pool-number 1 将以太接口的pppoe拨号客户端加入拨号池1

第三步:配置逻辑拨号接口:

interface Dialer1

ip address negotiated previous 自动协商获取IP地址(或从adsl服务商动态协商得到ip地址)

ip nat outside 为该接口启用NAT

encapsulation ppp 为该接口封装ppp协议

dialer pool 1 该接口使用1号拨号池进行拨号

dialer-group 1 该接口使用1号拨号池组进行拨号,对应拨号池的数字

ppp authentication pap callin 启用ppp pap验证 名称为callin

ppp pap sent-username admin password 0 123456 使用已经申请的用户名和口令(0表示对密

码的加密级别为0,即不对密码加密,共有0-7个级别)

第四步:配置内部网络接口

interface Ethernet 1/1 (内部网络接口)

ip address 192.168.1.1 255.255.255.0

ip nat inside 为该接口启用NAT

第五步:配置路由器为内部网络主机提供dhcp服务

ip dhcp excluded-address 192.168.1.1 该IP不会被DHCP分配

ip dhcp pool dhcp-test 配置dhcp地址池

import all (导入dns和wins server)

network 192.168.1.0 255.255.255.0 DHCP地址池的IP地址范围

default-router 192.168.1.1 设定默认路由(即网关)

第六步:配置NAT:

access-list 1 permit 10.1.1.0 0.0.0.255 设定允许访问外网的IP地址范围

ip nat inside source list 1 interface Dialer 1 overload 设定NAT地址转换的源IP

及出口端口,list 1 为源允许访问的IP通过acl列表定义的,interface dialer 1为内网访问

外网的出口端口。overload表示可以复用公网IP,以保证所有内网IP都能访问公网。

第七步:配置缺省路由

ip route 0.0.0.0 0.0.0.0 Dialer1

上一篇:家用无线路由器安全设置方法教程
下一篇:基础网络详情
相关文章
图文推荐

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站