频道栏目
首页 > 网络 > 路由器 > 正文

静态路由的不通配置方式问题

2017-11-10 14:08:59      个评论    来源:鸢舞苍穷 的BLOG   
收藏   我要投稿

1 ip route x.x.x.x. y.y.y.y (端口)

这个端口必须是设备自己的

2 ip route x.x.x.x. y.y.y.y (ip--address)

这个IP地址必须是对端设备与自己

<互联时使用的那个接口的IP地址>

注意:网关是一个端口的概念,不是一个设备的概念

网关(端口)所在的设备,必须具备"路由"的功能

凡是具备"路由功能"的设备在通信时才会使用到网关,同网段设备通信,不需要配置网关

书写静态路由时候,强烈建议使用对端设备IP地址

路由器查找路由条目的原则;

当路由器进行数据包与路由表条目匹配时

如果有多个条目可以同时匹配,则选择子网

掩码长的那个条目进行转发,这叫做最长匹配原则.

特殊路由条目;

0.0.0.0/0------>表示的时所有的网络<称为默认路由>

配制:ip route 0.0.0.0 0.0.0.0 10.10.23.2

交换:同网段通信叫交换(交换不通,看MAC和交换机的转发条目)

路由:不同网段通信叫路由(路由不通,看IP和路由的转发条目)

案例--1

实验名称:静态路由配置与实现

实验拓补:

实验需求: 1 基于网络拓补进行编址

2 确保PC-1与PC-2互通

实验配置:
1、配置终端 PC-1 的 IP 相关信息;
ip - 192.168.1.1
mask - 255.255.255.0
gateway - 192.168.1.250
2、配置 R1 的接口 IP 地址信息;
interface gi0/1
no shutdown
ip address 192.168.1.250 255.255.255.0
exit
interface gi0/0
no shutdown
ip address 10.10.12.1 255.255.255.0
exit
3、配置 R2 的接口 IP 地址信息; 
   interface gi0/2
no shutdown
ip address 10.10.12.2 255.255.255.0
exit
interfasce gi0/1
no shutdown
ip address 192.168.2.250 255.255.255.0
exit
4、配置终端 PC-2 的IP相关信息;
ip - 192.168.2.1
mask - 255.255.255.0
gateway - 192.168.2.250
5、确保 PC-1 的网关可以去往 PC-2所在网段;
R1:
ip route 192.168.2.0 255.255.255.0 10.10.12.2
6、确保 PC-2 的网关有返回到 PC-1 所在网段的路由;
R2:
ip route 192.168.1.0 255.255.255.0 10.10.12.1
验证命令:
show ip interface
show ip route
PC-1/2 :
ping 192.168.2.1
ping 192.168.1.1

上一篇:路由介绍与相关静态路由条目的配置与操作
下一篇:最后一页
相关文章
图文推荐

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站