频道栏目
首页 > 资讯 > CCIE > 正文

BGP反射综合实验案例

11-07-18        来源:[db:作者]  
收藏   我要投稿

 

r1#show running-config
Building configuration...
 
Current configuration : 1032 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
!
interface Serial0/0
 ip address 192.168.1.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 100
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 192.168.1.2 remote-as 200
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
control-plane
line con 0
line aux 0
line vty 0 4
 login
!
!
End
 
 
 
 
 
 
 
r2#show running-config
Building configuration...
 
Current configuration : 1233 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
interface Loopback2
 ip address 2.2.2.2 255.255.255.0
!
interface Serial0/0
 ip address 192.168.1.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 192.168.2.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 2.2.2.0 0.0.0.255
 network 192.168.2.0
 no auto-summary
!
router bgp 200
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 network 2.2.2.0 mask 255.255.255.0
 neighbor 3.3.3.3 remote-as 200
 neighbor 3.3.3.3 update-source Loopback2
 neighbor 3.3.3.3 next-hop-self
 neighbor 192.168.1.1 remote-as 100
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
control-plane
line con 0
line aux 0
line vty 0 4
 login
End
 
 
 
 
 
 
 
r3#show running-config
Building configuration...
 
Current configuration : 2019 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
interface Loopback3
 ip address 3.3.3.3 255.255.255.0
!
interface Serial0/0
 ip address 192.168.4.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 192.168.2.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 ip address 192.168.5.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/3
 ip address 192.168.3.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/0
 ip address 192.168.6.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 3.3.3.0 0.0.0.255
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.5.0
 no auto-summary
!
router bgp 200
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 network 3.3.3.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 200
 neighbor 2.2.2.2 update-source Loopback3
 neighbor 2.2.2.2 route-reflector-client
 neighbor 2.2.2.2 next-hop-self
 neighbor 4.4.4.4 remote-as 200
 neighbor 4.4.4.4 update-source Loopback3
 neighbor 4.4.4.4 next-hop-self
 neighbor 5.5.5.5 remote-as 200
 neighbor 5.5.5.5 update-source Loopback3
 neighbor 5.5.5.5 next-hop-self
 neighbor 6.6.6.6 remote-as 200
 neighbor 6.6.6.6 update-source Loopback3
 neighbor 6.6.6.6 route-reflector-client
 neighbor 6.6.6.6 next-hop-self
 neighbor 192.168.6.2 remote-as 300
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
control-plane
line con 0
line aux 0
line vty 0 4
 login
!
!
End
 
 
 
 
 
 
 
 
r4#show running-config
Building configuration...
 
Current configuration : 1152 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
interface Loopback4
 ip address 4.4.4.4 255.255.255.0
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 ip address 192.168.3.2 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 4.4.4.0 0.0.0.255
 network 192.168.3.0
 no auto-summary
!
router bgp 200
 no synchronization
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 network 4.4.4.0 mask 255.255.255.0
 neighbor 3.3.3.3 remote-as 200
 neighbor 3.3.3.3 update-source Loopback4
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
control-plane
line con 0
line aux 0
line vty 0 4
 login
!
!
End
 
 
 
 
 
 
r5#show running-config
Building configuration...
 
Current configuration : 1152 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r5
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
interface Loopback5
 ip address 5.5.5.5 255.255.255.0
!
interface Serial0/0
 ip address 192.168.4.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 5.5.5.0 0.0.0.255
 network 192.168.4.0
 no auto-summary
!
router bgp 200
 no synchronization
 bgp router-id 5.5.5.5
 bgp log-neighbor-changes
 network 5.5.5.0 mask 255.255.255.0
 neighbor 3.3.3.3 remote-as 200
 neighbor 3.3.3.3 update-source Loopback5
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
control-plane
line con 0
line aux 0
line vty 0 4
 login
!
!
End
 
 
 
 
 
 
 
 
 
 
r6#show running-config
Building configuration...
 
Current configuration : 1152 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r6
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
interface Loopback6
 ip address 6.6.6.6 255.255.255.0
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 ip address 192.168.5.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 6.6.6.0 0.0.0.255
 network 192.168.5.0
 no auto-summary
!
router bgp 200
 no synchronization
 bgp router-id 6.6.6.6
 bgp log-neighbor-changes
 network 6.6.6.0 mask 255.255.255.0
 neighbor 3.3.3.3 remote-as 200
 neighbor 3.3.3.3 update-source Loopback6
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
control-plane
line con 0
line aux 0
line vty 0 4
 login
End
 
 
 
 
 
 
 
 
r7#show running-config
Building configuration...
 
Current configuration : 1032 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r7
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef
ip ips po max-events 100
no ftp-server write-enable
interface Loopback7
 ip address 7.7.7.7 255.255.255.0
!
interface Serial0/0
 ip address 192.168.6.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 300
 no synchronization
 bgp router-id 7.7.7.7
 bgp log-neighbor-changes
 network 7.7.7.0 mask 255.255.255.0
 neighbor 192.168.6.1 remote-as 200
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
control-plane
line con 0
line aux 0
line vty 0 4
 login
!
!
End
 
 
验证:
分别在各个路由器上使用show ip bgp show ip route 命令查看
R1:
 
R2:
 
 
 
R3:
 
 
R4:
 
 
R5:
 
 
R6:
 
 
R7:
 
 
 
本文出自 “IT梦-齐-分享” 博客
 
相关TAG标签
上一篇:GRE VPN配置实例
下一篇:全网互通静态路由
相关文章
图文推荐

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站